#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[-+]?[0-9]+(?:,[0-9]{3})*(?:\.[0-9]+)?$"
Local $sString = "3200" & @CRLF & _
"3,200" & @CRLF & _
"3,200.00" & @CRLF & _
"3,2,3,6,5,6.2" & @CRLF & _
"3,223,334,643,544,446.2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")