const regex = /^[-+]?[0-9]+(?:,[0-9]{3})*(?:\.[0-9]+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[-+]?[0-9]+(?:,[0-9]{3})*(?:\\.[0-9]+)?$', 'gm')
const str = `3200
3,200
3,200.00
3,2,3,6,5,6.2
3,223,334,643,544,446.2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}