// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[-+]?[0-9]+(?:,[0-9]{3})*(?:\.[0-9]+)?$").unwrap();
let string = "3200
3,200
3,200.00
3,2,3,6,5,6.2
3,223,334,643,544,446.2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}