use strict;
my $str = '3200
3,200
3,200.00
3,2,3,6,5,6.2
3,223,334,643,544,446.2';
my $regex = qr/^[-+]?[0-9]+(?:,[0-9]{3})*(?:\.[0-9]+)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}