re = /^[-+]?[0-9]+(?:,[0-9]{3})*(?:\.[0-9]+)?$/m
str = '3200
3,200
3,200.00
3,2,3,6,5,6.2
3,223,334,643,544,446.2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end