using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*[.-](?=[.-]))[^.-][a-z0-9.-]{1,61}[^.-]$";
string input = @"abc-123.xyz
abc123-.xyz
123456789012345678901234567890123456789012345678901234567890123
1234567890123456789012345678901234567890123456789012345678901234";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}