re = /^(?!.*[.-](?=[.-]))[^.-][a-z0-9.-]{1,61}[^.-]$/m
str = 'abc-123.xyz
abc123-.xyz
123456789012345678901234567890123456789012345678901234567890123
1234567890123456789012345678901234567890123456789012345678901234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end