import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*[.-](?=[.-]))[^.-][a-z0-9.-]{1,61}[^.-]$";
final String string = "abc-123.xyz\n"
+ "abc123-.xyz \n"
+ "123456789012345678901234567890123456789012345678901234567890123\n\n"
+ "1234567890123456789012345678901234567890123456789012345678901234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}