#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)([^_]function\s?\()+"
Local $sString = "function( testing regex function( bla bla newfunction( alternative function ( not capture this mb_function( or mb_function ( need a right regex. need only capture "function(" or "function (" and not start mb_ ex: mb_function( how to fix ? im using regex in windows10 powershell command line replace function."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")