import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^_]function\\s?\\()+";
final String string = "function( testing regex function( bla bla newfunction( alternative function ( not capture this mb_function( or mb_function ( need a right regex. need only capture \"function(\" or \"function (\" and not start mb_ ex: mb_function( how to fix ? im using regex in windows10 powershell command line replace function.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}