const regex = /([^_]function\s?\()+/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^_]function\\s?\\()+', 'gmi')
const str = `function( testing regex function( bla bla newfunction( alternative function ( not capture this mb_function( or mb_function ( need a right regex. need only capture "function(" or "function (" and not start mb_ ex: mb_function( how to fix ? im using regex in windows10 powershell command line replace function.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}