$re = '/([^_]function\s?\()+/mi';
$str = 'function( testing regex function( bla bla newfunction( alternative function ( not capture this mb_function( or mb_function ( need a right regex. need only capture "function(" or "function (" and not start mb_ ex: mb_function( how to fix ? im using regex in windows10 powershell command line replace function.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);