package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)([^_]function\s?\()+`)
var str = `function( testing regex function( bla bla newfunction( alternative function ( not capture this mb_function( or mb_function ( need a right regex. need only capture "function(" or "function (" and not start mb_ ex: mb_function( how to fix ? im using regex in windows10 powershell command line replace function.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}