// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)([^_]function\s?\()+").unwrap();
let string = "function( testing regex function( bla bla newfunction( alternative function ( not capture this mb_function( or mb_function ( need a right regex. need only capture \"function(\" or \"function (\" and not start mb_ ex: mb_function( how to fix ? im using regex in windows10 powershell command line replace function.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}