package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\d{3}.*|([\w\+$#/\\]{6,})`)
var str = `pass12p
pass125p
asdfasf12asdf34
asdfasf12345asdf34`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}