$re = '/.*\d{3}.*|([\w\+$#/\\\\]{6,})/';
$str = 'pass12p
pass125p
asdfasf12asdf34
asdfasf12345asdf34';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);