import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\d{3}.*|([\\w\\+$#/\\\\]{6,})";
final String string = "pass12p\n"
+ "pass125p\n"
+ "asdfasf12asdf34\n"
+ "asdfasf12345asdf34";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}