using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:LOG:)(?:[^,]*,){4}(?!00?)([^,]*).*$";
string substitution = @"";
string input = @"LOG:69369,1,30,40,80,06,1
LOG:69369,1,30,40,C0,06,1
POS:69453,69576034,-19244227,1,0
LOG:69405,2,30,40,00,06,2
POS:69333,69576024,-19244235,1,0
LOG:69405,2,30,40,C0,06,2 ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}