import re
regex = re.compile(r"^(?:LOG:)(?:[^,]*,){4}(?!00?)([^,]*).*$", flags=re.MULTILINE)
test_str = ("LOG:69369,1,30,40,80,06,1\n"
"LOG:69369,1,30,40,C0,06,1\n"
"POS:69453,69576034,-19244227,1,0\n"
"LOG:69405,2,30,40,00,06,2\n"
"POS:69333,69576024,-19244235,1,0\n"
"LOG:69405,2,30,40,C0,06,2 ")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)