const regex = /^(?:LOG:)(?:[^,]*,){4}(?!00?)([^,]*).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:LOG:)(?:[^,]*,){4}(?!00?)([^,]*).*$', 'gm')
const str = `LOG:69369,1,30,40,80,06,1
LOG:69369,1,30,40,C0,06,1
POS:69453,69576034,-19244227,1,0
LOG:69405,2,30,40,00,06,2
POS:69333,69576024,-19244235,1,0
LOG:69405,2,30,40,C0,06,2 `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);