#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?iux)(^|\R)((.*(\b|\.))\s-\s\b(.*(\b|\.)))(\R|$)"
Local $sString = "Одесса - Москва" & @CRLF & _
"" & @CRLF & _
"Москва - Одесса" & @CRLF & _
"" & @CRLF & _
"Абу куку ари гами - Салат" & @CRLF & _
"" & @CRLF & _
"Салат - Абу куку ари гами" & @CRLF & _
"" & @CRLF & _
"Абакан - Алтайская" & @CRLF & _
"" & @CRLF & _
"Вязовая - Золотинка" & @CRLF & _
"" & @CRLF & _
"Кемь - Семигородная" & @CRLF & _
"" & @CRLF & _
"Можга - Иланская" & @CRLF & _
"" & @CRLF & _
"Ясногорск - Тарбагатай" & @CRLF & _
"" & @CRLF & _
"Выя - рзд.135км" & @CRLF & _
"" & @CRLF & _
"134 - 8787" & @CRLF & _
"" & @CRLF & _
"134 км - 8787" & @CRLF & _
"" & @CRLF & _
"Кежемская - Сальск" & @CRLF & _
"" & @CRLF & _
"Вышний Волочёк - Санкт-Петербуг" & @CRLF & _
"" & @CRLF & _
"Кежемская - Зимовники" & @CRLF & _
"" & @CRLF & _
"Могойтуй - Тинская" & @CRLF & _
"" & @CRLF & _
"Пыть-Ях - Усть-Юган" & @CRLF & _
"" & @CRLF & _
"Торбеево - Сызрань" & @CRLF & _
"" & @CRLF & _
"Ясная - Забайкальск" & @CRLF & _
"" & @CRLF & _
"Вышний Волочёк - Санкт-Петербург" & @CRLF & _
"" & @CRLF & _
"Могойтуй - Улан-Удэ" & @CRLF & _
"" & @CRLF & _
"Улан-Батор - Балезино" & @CRLF & _
"" & @CRLF & _
"Ангарск - Номжа" & @CRLF & _
"" & @CRLF & _
"Дальнереченск - Находка" & @CRLF & _
"" & @CRLF & _
"Коксу - Сеятель" & @CRLF & _
"" & @CRLF & _
"Неверовская - Ульба-Перевалочная" & @CRLF & _
"" & @CRLF & _
"Россошь - Моздок" & @CRLF & _
"" & @CRLF & _
"Улан-Батор - Барабинск" & @CRLF & _
"" & @CRLF & _
"Ангарск - рзд.№71" & @CRLF & _
"" & @CRLF & _
"Остров Н.О. - рзд.303км" & @CRLF & _
"" & @CRLF & _
"рзд.303км - Аксака" & @CRLF & _
"" & @CRLF & _
"Гротовский - Семиглавый Мар" & @CRLF & _
"" & @CRLF & _
"Княжая - Масельская" & @CRLF & _
"" & @CRLF & _
"Мюд - Кесова Гора" & @CRLF & _
"" & @CRLF & _
"рзд.Туюн - Уркальту" & @CRLF & _
"" & @CRLF & _
"Тяжин - Чильчи" & @CRLF & _
"" & @CRLF & _
"Мюд - Москва" & @CRLF & _
"" & @CRLF & _
"Вязьма - Остров Н.О." & @CRLF & _
"" & @CRLF & _
"Москва - Берлин" & @CRLF & _
"" & @CRLF & _
"Кенада - рзд.303км"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")