use strict;
my $str = 'Одесса - Москва
Москва - Одесса
Абу куку ари гами - Салат
Салат - Абу куку ари гами
Абакан - Алтайская
Вязовая - Золотинка
Кемь - Семигородная
Можга - Иланская
Ясногорск - Тарбагатай
Выя - рзд.135км
134 - 8787
134 км - 8787
Кежемская - Сальск
Вышний Волочёк - Санкт-Петербуг
Кежемская - Зимовники
Могойтуй - Тинская
Пыть-Ях - Усть-Юган
Торбеево - Сызрань
Ясная - Забайкальск
Вышний Волочёк - Санкт-Петербург
Могойтуй - Улан-Удэ
Улан-Батор - Балезино
Ангарск - Номжа
Дальнереченск - Находка
Коксу - Сеятель
Неверовская - Ульба-Перевалочная
Россошь - Моздок
Улан-Батор - Барабинск
Ангарск - рзд.№71
Остров Н.О. - рзд.303км
рзд.303км - Аксака
Гротовский - Семиглавый Мар
Княжая - Масельская
Мюд - Кесова Гора
рзд.Туюн - Уркальту
Тяжин - Чильчи
Мюд - Москва
Вязьма - Остров Н.О.
Москва - Берлин
Кенада - рзд.303км';
my $regex = qr/(^|\R)((.*(\b|\.))\s-\s\b(.*(\b|\.)))(\R|$)/iuxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}