using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|\R)((.*(\b|\.))\s-\s\b(.*(\b|\.)))(\R|$)";
string input = @"Одесса - Москва
Москва - Одесса
Абу куку ари гами - Салат
Салат - Абу куку ари гами
Абакан - Алтайская
Вязовая - Золотинка
Кемь - Семигородная
Можга - Иланская
Ясногорск - Тарбагатай
Выя - рзд.135км
134 - 8787
134 км - 8787
Кежемская - Сальск
Вышний Волочёк - Санкт-Петербуг
Кежемская - Зимовники
Могойтуй - Тинская
Пыть-Ях - Усть-Юган
Торбеево - Сызрань
Ясная - Забайкальск
Вышний Волочёк - Санкт-Петербург
Могойтуй - Улан-Удэ
Улан-Батор - Балезино
Ангарск - Номжа
Дальнереченск - Находка
Коксу - Сеятель
Неверовская - Ульба-Перевалочная
Россошь - Моздок
Улан-Батор - Барабинск
Ангарск - рзд.№71
Остров Н.О. - рзд.303км
рзд.303км - Аксака
Гротовский - Семиглавый Мар
Княжая - Масельская
Мюд - Кесова Гора
рзд.Туюн - Уркальту
Тяжин - Чильчи
Мюд - Москва
Вязьма - Остров Н.О.
Москва - Берлин
Кенада - рзд.303км";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.CultureInvariant | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}