import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"(^|\R)((.*(\b|\.))\s-\s\b(.*(\b|\.)))(\R|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
Одесса - Москва
Москва - Одесса
Абу куку ари гами - Салат
Салат - Абу куку ари гами
Абакан - Алтайская
Вязовая - Золотинка
Кемь - Семигородная
Можга - Иланская
Ясногорск - Тарбагатай
Выя - рзд.135км
134 - 8787
134 км - 8787
Кежемская - Сальск
Вышний Волочёк - Санкт-Петербуг
Кежемская - Зимовники
Могойтуй - Тинская
Пыть-Ях - Усть-Юган
Торбеево - Сызрань
Ясная - Забайкальск
Вышний Волочёк - Санкт-Петербург
Могойтуй - Улан-Удэ
Улан-Батор - Балезино
Ангарск - Номжа
Дальнереченск - Находка
Коксу - Сеятель
Неверовская - Ульба-Перевалочная
Россошь - Моздок
Улан-Батор - Барабинск
Ангарск - рзд.№71
Остров Н.О. - рзд.303км
рзд.303км - Аксака
Гротовский - Семиглавый Мар
Княжая - Масельская
Мюд - Кесова Гора
рзд.Туюн - Уркальту
Тяжин - Чильчи
Мюд - Москва
Вязьма - Остров Н.О.
Москва - Берлин
Кенада - рзд.303км
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)