const regex = /(^|\R)((.*(\b|\.))\s-\s\b(.*(\b|\.)))(\R|$)/iug;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\R)((.*(\\b|\\.))\\s-\\s\\b(.*(\\b|\\.)))(\\R|$)', 'iug')
const str = `Одесса - Москва
Москва - Одесса
Абу куку ари гами - Салат
Салат - Абу куку ари гами
Абакан - Алтайская
Вязовая - Золотинка
Кемь - Семигородная
Можга - Иланская
Ясногорск - Тарбагатай
Выя - рзд.135км
134 - 8787
134 км - 8787
Кежемская - Сальск
Вышний Волочёк - Санкт-Петербуг
Кежемская - Зимовники
Могойтуй - Тинская
Пыть-Ях - Усть-Юган
Торбеево - Сызрань
Ясная - Забайкальск
Вышний Волочёк - Санкт-Петербург
Могойтуй - Улан-Удэ
Улан-Батор - Балезино
Ангарск - Номжа
Дальнереченск - Находка
Коксу - Сеятель
Неверовская - Ульба-Перевалочная
Россошь - Моздок
Улан-Батор - Барабинск
Ангарск - рзд.№71
Остров Н.О. - рзд.303км
рзд.303км - Аксака
Гротовский - Семиглавый Мар
Княжая - Масельская
Мюд - Кесова Гора
рзд.Туюн - Уркальту
Тяжин - Чильчи
Мюд - Москва
Вязьма - Остров Н.О.
Москва - Берлин
Кенада - рзд.303км`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}