// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?iux)(^|\R)((.*(\b|\.))\s-\s\b(.*(\b|\.)))(\R|$)").unwrap();
let string = "Одесса - Москва
Москва - Одесса
Абу куку ари гами - Салат
Салат - Абу куку ари гами
Абакан - Алтайская
Вязовая - Золотинка
Кемь - Семигородная
Можга - Иланская
Ясногорск - Тарбагатай
Выя - рзд.135км
134 - 8787
134 км - 8787
Кежемская - Сальск
Вышний Волочёк - Санкт-Петербуг
Кежемская - Зимовники
Могойтуй - Тинская
Пыть-Ях - Усть-Юган
Торбеево - Сызрань
Ясная - Забайкальск
Вышний Волочёк - Санкт-Петербург
Могойтуй - Улан-Удэ
Улан-Батор - Балезино
Ангарск - Номжа
Дальнереченск - Находка
Коксу - Сеятель
Неверовская - Ульба-Перевалочная
Россошь - Моздок
Улан-Батор - Барабинск
Ангарск - рзд.№71
Остров Н.О. - рзд.303км
рзд.303км - Аксака
Гротовский - Семиглавый Мар
Княжая - Масельская
Мюд - Кесова Гора
рзд.Туюн - Уркальту
Тяжин - Чильчи
Мюд - Москва
Вязьма - Остров Н.О.
Москва - Берлин
Кенада - рзд.303км";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}