#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<([a-z]+).*(?<!\/)>"
Local $sString = "<div>" & @CRLF & _
" <p class="content">" & @CRLF & _
" Consider the SUT safe." & @CRLF & _
" <a href="https://www.google.com">" & @CRLF & _
" Google" & @CRLF & _
" </a>" & @CRLF & _
" is your friend. <br />" & @CRLF & _
" Another line here." & @CRLF & _
" <hr class="divider" />" & @CRLF & _
" Final line" & @CRLF & _
" </p>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")