import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<([a-z]+).*(?<!\\/)>";
final String string = "<div>\n"
+ " <p class=\"content\">\n"
+ " Consider the SUT safe.\n"
+ " <a href=\"https://www.google.com\">\n"
+ " Google\n"
+ " </a>\n"
+ " is your friend. <br />\n"
+ " Another line here.\n"
+ " <hr class=\"divider\" />\n"
+ " Final line\n"
+ " </p>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}