re = /<([a-z]+).*(?<!\/)>/
str = '<div>
<p class="content">
Consider the SUT safe.
<a href="https://www.google.com">
Google
</a>
is your friend. <br />
Another line here.
<hr class="divider" />
Final line
</p>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end