$re = '/<([a-z]+).*(?<!\/)>/';
$str = '<div>
<p class="content">
Consider the SUT safe.
<a href="https://www.google.com">
Google
</a>
is your friend. <br />
Another line here.
<hr class="divider" />
Final line
</p>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);