using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<([a-z]+).*(?<!\/)>";
string input = @"<div>
<p class=""content"">
Consider the SUT safe.
<a href=""https://www.google.com"">
Google
</a>
is your friend. <br />
Another line here.
<hr class=""divider"" />
Final line
</p>
</div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}