import re
regex = re.compile(r"<([a-z]+).*(?<!\/)>")
test_str = ("<div>\n"
" <p class=\"content\">\n"
" Consider the SUT safe.\n"
" <a href=\"https://www.google.com\">\n"
" Google\n"
" </a>\n"
" is your friend. <br />\n"
" Another line here.\n"
" <hr class=\"divider\" />\n"
" Final line\n"
" </p>\n"
"</div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")