#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\B(?=(\d{3})+(?!\d))"
Local $sString = "12345678"
Local $sSubst = ","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)