import Foundation
let pattern = #"\B(?=(\d{3})+(?!\d))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"12345678"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)