use strict;
my $str = '12345678';
my $regex = qr/\B(?=(\d{3})+(?!\d))/p;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";