$re = '/\B(?=(\d{3})+(?!\d))/';
$str = '12345678';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;