const regex = /\B(?=(\d{3})+(?!\d))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\B(?=(\\d{3})+(?!\\d))', 'g')
const str = `12345678`;
const subst = `,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);