using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\B(?=(\d{3})+(?!\d))";
string substitution = @",";
string input = @"12345678";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}