using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<protocol>(?:http|ftp|irc)s?:\/\/)?(?:(?<user>[^:\n\r]+):(?<pass>[^@\n\r]+)@)?(?<host>(?:www\.)?(?:[^:\/\n\r]+)(?::(?<port>\d+))?)\/?(?<request>[^?#\n\r]+)?\??(?<query>[^#\n\r]*)?\#?(?<anchor>[^\n\r]*)?";
string input = @"http://user:pass@some.example.com:80/directory/sub/place?C=M;O=A#nth
http://some.example.com/some/path/to/a/file.bin?request;part=1#somewhere
https://www.example.com
ircs://example.server.net:6697/#channel
irc://irc.example.org/channel
ftp://www.place.example.gov/
www.places.to.be
somewhere.to/go";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}