import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<protocol>(?:http|ftp|irc)s?:\\/\\/)?(?:(?<user>[^:\\n\\r]+):(?<pass>[^@\\n\\r]+)@)?(?<host>(?:www\\.)?(?:[^:\\/\\n\\r]+)(?::(?<port>\\d+))?)\\/?(?<request>[^?#\\n\\r]+)?\\??(?<query>[^#\\n\\r]*)?\\#?(?<anchor>[^\\n\\r]*)?";
final String string = "http://user:pass@some.example.com:80/directory/sub/place?C=M;O=A#nth\n"
+ "http://some.example.com/some/path/to/a/file.bin?request;part=1#somewhere\n"
+ "https://www.example.com\n"
+ "ircs://example.server.net:6697/#channel\n"
+ "irc://irc.example.org/channel\n"
+ "ftp://www.place.example.gov/\n"
+ "www.places.to.be\n"
+ "somewhere.to/go";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}