const regex = /(?<protocol>(?:http|ftp|irc)s?:\/\/)?(?:(?<user>[^:\n\r]+):(?<pass>[^@\n\r]+)@)?(?<host>(?:www\.)?(?:[^:\/\n\r]+)(?::(?<port>\d+))?)\/?(?<request>[^?#\n\r]+)?\??(?<query>[^#\n\r]*)?\#?(?<anchor>[^\n\r]*)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<protocol>(?:http|ftp|irc)s?:\\\/\\\/)?(?:(?<user>[^:\\n\\r]+):(?<pass>[^@\\n\\r]+)@)?(?<host>(?:www\\.)?(?:[^:\\\/\\n\\r]+)(?::(?<port>\\d+))?)\\\/?(?<request>[^?#\\n\\r]+)?\\??(?<query>[^#\\n\\r]*)?\\#?(?<anchor>[^\\n\\r]*)?', 'gm')
const str = `http://user:pass@some.example.com:80/directory/sub/place?C=M;O=A#nth
http://some.example.com/some/path/to/a/file.bin?request;part=1#somewhere
https://www.example.com
ircs://example.server.net:6697/#channel
irc://irc.example.org/channel
ftp://www.place.example.gov/
www.places.to.be
somewhere.to/go`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}