package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<protocol>(?:http|ftp|irc)s?:\/\/)?(?:(?<user>[^:\n\r]+):(?<pass>[^@\n\r]+)@)?(?<host>(?:www\.)?(?:[^:\/\n\r]+)(?::(?<port>\d+))?)\/?(?<request>[^?#\n\r]+)?\??(?<query>[^#\n\r]*)?\#?(?<anchor>[^\n\r]*)?`)
var str = `http://user:pass@some.example.com:80/directory/sub/place?C=M;O=A#nth
http://some.example.com/some/path/to/a/file.bin?request;part=1#somewhere
https://www.example.com
ircs://example.server.net:6697/#channel
irc://irc.example.org/channel
ftp://www.place.example.gov/
www.places.to.be
somewhere.to/go`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}