#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([a-z][A-Za-z\d]*(\.[a-z][A-Za-z\d]*){1,6})|([A-Z][A-Za-z\d]+(\.[A-Z][A-Za-z\d]*){0,3}))$"
Local $sString = "org.bh.tools.ui.fx.latte" & @CRLF & _
"LatteFX"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")