re = /^(([a-z][A-Za-z\d]*(\.[a-z][A-Za-z\d]*){1,6})|([A-Z][A-Za-z\d]+(\.[A-Z][A-Za-z\d]*){0,3}))$/m
str = 'org.bh.tools.ui.fx.latte
LatteFX'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end