const regex = /^(([a-z][A-Za-z\d]*(\.[a-z][A-Za-z\d]*){1,6})|([A-Z][A-Za-z\d]+(\.[A-Z][A-Za-z\d]*){0,3}))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([a-z][A-Za-z\\d]*(\\.[a-z][A-Za-z\\d]*){1,6})|([A-Z][A-Za-z\\d]+(\\.[A-Z][A-Za-z\\d]*){0,3}))$', 'gm')
const str = `org.bh.tools.ui.fx.latte
LatteFX`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}