import re
regex = re.compile(r"^(([a-z][A-Za-z\d]*(\.[a-z][A-Za-z\d]*){1,6})|([A-Z][A-Za-z\d]+(\.[A-Z][A-Za-z\d]*){0,3}))$", flags=re.MULTILINE)
test_str = ("org.bh.tools.ui.fx.latte\n"
"LatteFX")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")