package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([a-z][A-Za-z\d]*(\.[a-z][A-Za-z\d]*){1,6})|([A-Z][A-Za-z\d]+(\.[A-Z][A-Za-z\d]*){0,3}))$`)
var str = `org.bh.tools.ui.fx.latte
LatteFX`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}