import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([a-z][A-Za-z\\d]*(\\.[a-z][A-Za-z\\d]*){1,6})|([A-Z][A-Za-z\\d]+(\\.[A-Z][A-Za-z\\d]*){0,3}))$";
final String string = "org.bh.tools.ui.fx.latte\n"
+ "LatteFX";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}