# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ ?\(\w+\)//g;t' <<< "x (LOC)
ds ds (32C)
d'ds ds (LeC)
ds-d da(LOQ)
12345 (deC)
"