package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(` ?\(\w+\)`)
var str = `x (LOC)
ds ds (32C)
d'ds ds (LeC)
ds-d da(LOQ)
12345 (deC)
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}